Investigation of anaconda.org outage
Incident Report for Anaconda
Resolved
This was resolved with the release on 2022-11-30. We left this incident open in case there were any issues with the release. Seeing none, we consider this resolved.
Posted Jan 05, 2023 - 21:03 UTC
Monitoring
Yesterday's changes to correct DB performance issues have been effective, and we continue to watch for anything unusual. We will mark this incident Resolved once the new server release is fully rolled out.
Posted Nov 30, 2022 - 14:34 UTC
Identified
The cause of the anaconda.org outages (yesterday and today) has been identified. An update is ready to be deployed which will allow the secondary mongodb nodes to serve some of the read requests, which should mitigate the issue.

We anticipate password reset requests may be partially affected by this change until the subsequent server release, which is scheduled for tomorrow, 2022-11-30.

If you are trying to change your password on anaconda.org - it may take multiple attempts before your reset request is successful. This is a temporary issue and will be resolved by tomorrow's update.
Posted Nov 29, 2022 - 16:50 UTC
Investigating
Looking for a root cause of today's earlier outage.
Posted Nov 28, 2022 - 22:37 UTC
This incident affected: Anaconda.org (Anaconda.org Front End Web Service).